Comment on page

Tool Orders User Guide

1.0 - Introduction

As of version 2.0.6.12, Well Seeker Pro now contains the Tool Orders functionality. Tool Orders is a licensed feature that is designed to give an organization the means by which to create, update and maintain oversight of all the tool requirements for upcoming and existing jobs. The Tool Orders will be managed from the server database, but local database users at the rig site can also create tool orders and push these back to the server for approval, should the requirement for more tools occur during an ongoing job.
The way in which Tool Orders can be accessed and used differs between the server and local database. The remainder of the document will guide the user through the specifics of the setup on the server and any subsequent utilization from a local database.

2.0 – Tool Orders – SQL Server Database

The below steps assume that the user already has a Well Seeker Pro SQL server database:
1. Log on to the SQL server database
2. Select Tools > Dashboards > Tool Orders Dashboard
3. The Tool Orders dialog will open. Prior to the first use of the Tool Orders it is recommended that the user input all the of the available tool order options that users will be able to select when creating a tool order in future. Select either Tools > Edit drop down menus or the
icon from the toolbar.
4. Input details for each of the tool order detail types in the Select menu option dropdown list. This will form the basis of what tool configurations the user can specifically ask for when using the Tool Orders dialog. This can be edited at a later date if required. When the user has filled in all of the relevant options, select Apply and then close the dialog.
5. To add a new Tool Order select Tools > Create new tool order or select the
icon from the toolbar. This will create a new row in the Tool Orders table.
6. Fill in the relevant details in the Tool Orders table:
  • If the tool order is for a job that has no daily reporting data yet, i.e. an upcoming job, then the user would input the Operator, Job # and Well information and leave the Hole Size, State, County, Rig, Mud Type, Mud Weight, Min Temp and Max Temp inputs blank.
  • If the tool order is for an existing job which has daily reporting data input within the database, the user would enter the Job # only and the rest of the cells will populate based upon the daily reporting data.
  • Update the Date Needed cell. This defaults to the date the tool order was created.
  • Input any additional information in the remaining cells.
7. Fill in the relevant details in the Order Details table. Some cells will be manually input, others will be selectable from the dropdown menu, the choices of which the user has set up previously. More than one row for multiple tools may be input in this section.
8. The Tool Order has been completed. By default the tool order status is Draft. This should be changed to Submitted when the details are finalized. The status can be updated sequentially as the tool order is In Progress, Shipped and Complete.
9. At any stage a tool order can be printed or attached to an email. Firstly select the tool order from the Tool Order table. In the Order Details table, check the Print cell for any row that you wish to be included in the printed report.
10. Any tool orders with the status of Request from rig are a tool order that has been pushed from a local database to the server database. A user on the server can the approve this request for tools by selecting the tool order in question and selecting Tools > Approve order, or select the
icon on the toolbar. This will change the status from Request from rig to Submitted.
11. A tool orders status can be updated from the Status dropdown menu as the tool order progresses through its work cycle.

3.0 – Tool Orders – Local Database

The below steps assume that the user already has a Well Seeker Pro local database, populated with an actual wellbore:
1. Select the actual wellbore that the user requires and open the Tool Inventory, by selecting either the
Icon

Description automatically generated
icon from the toolbar, or right clicking on the actual wellbore in question and selecting Reporting > Tool Inventory.
2. In the Tool Inventory dialog select the
icon. This will open the Tool Orders dialog.
3. When the dialog opens it checks the IP and Port values entered in the Real Time Data Exchange dialog. If these are correct, then the dropdown menu options for the Order Details cells will be populated from the information on the server database.
4. Create the tool order and order details as you would on the server database. Any tool orders created on the local database will automatically be given the status of Request from rig.
5. To send this tool order request back to the server database, select the
icon, or select Tools > Send order to server. The tool order can then be approved by the administrators from the server database and acted upon.